Group Admins

  • Profile picture of Steve

WordPress Troubleshooting and Support

Public Group active 4 months, 2 weeks ago ago

WordPress support from our community

Site is slow to load

This topic contains 0 replies, has 3 voices, and was last updated by  D.K. Smith 6 years, 3 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #1613

    Sheryl Blasnik
    Participant

    Both my site and my WP Dashboard are super slow to load. I also am having problems uploading single images to my blog posts. I often have to switch to the media upload method.

    I did run Y SLOW on my site – Here are the results:

    Grade F on Make fewer HTTP requests
    This page has 23 external Javascript scripts. Try combining them into one.
    This page has 9 external stylesheets. Try combining them into one.
    This page has 17 external background images. Try combining them with CSS sprites.
    Decreasing the number of components on a page reduces the number of HTTP requests required to render the page, resulting in faster page loads. Some ways to reduce the number of components include: combine files, combine multiple scripts into one script, combine multiple CSS files into one style sheet, and use CSS Sprites and image maps.

    WHAT DO I NEED TO DO TO FIX THIS?

    Thanks

    Sheryl

    http://fashiondevelopmentgroup.com

    #2828

    Steve
    Keymaster

    Sheryl–

    When you load external files (JS, CSS, etc), it’s possible that your site can hang and wait for the other site to load. I the other site is slow… that will slow down your site.

    Other reasons for a slow site is a poorly coded theme or plugins… or just too many plugins.

    #2829

    D.K. Smith
    Participant

    @Sheryl… Your site may still be compromised. As mentioned previously, Sucuri DOES NOT catch everything (based on scores of other exploited sites). So there’s a good chance your site is still hacked.

    As for YSlow, the front-end “and” admin both running very slow goes beyond those results.

    The details you posted are fairly typical and generally not a reason both sides of a site would run very slow. Nothing there points a specific finger towards the issue(s).

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.