Group Admins

WordPress Troubleshooting and Support

Public Group active 1 year, 1 month ago ago

WordPress support from our community

Sidebar “extra bullet” after links

Tagged: ,

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
  • #1173
    Ed Altman

    This is a very simple site using the theme twentyten.

    On the sidebar, I have one widget – Links. I have two categories “Links” and “This is your site”. There are 8 links under “Links” and 1 under “This is…”.

    After each link in both sections there is what looks like a bullet but copying the string and putting in a hex editor shows that the “bullet” is a zero character “0”.

    I can not figure out where that is coming from.

    I’ve looked in sidebar.php and get as far as seeing that the output comes from
    if ( ! dynamic_sidebar( ‘primary-widget-area’ ) )
    but that’s where I get stuf.

    I’m somewhat code savvy – but I’m lost. Any help or pointers of where to investigate is greatly appreciate.



    Have you set up widgets on the theme, or is it using the default sidebar (no widgets set in the back end)

    Ed Altman

    I’ve set up one widget – “Links” – in the Primary widget area. No other widgets set up.



    Hi Ed–
    1) Have you made any changes to TwentyTen?
    2) What’s the url?


    Margarete Koenen

    Have you tried moving your links widget in the secondary widget area. Maybe that will help narrow it down.

    Ed Altman

    @Steve – I haven’t made any changes that I can recall. I can’t give out the URL because it’s password protected at the request of the users. I’ve posted a screen capture of it at

    @Margarete – Good suggestion – I moved the Links widget to all the other places but I still have the same problem.

    I tried to find the TwentyTen theme to download and reinstall. My my theme says version 1.2 and the only version I can find online is version 1.1.

    I checked the entries in the wp_links table and they don’t exist there.

    I still know I’m missing something fairly easy.

    Thank you still!


    Ed– two things to test:
    -disable all plugins to see if they are interfering.
    -use Firebug to see if it’s a css issue

    Margarete Koenen

    They don’t look like zeros or ‘o’s to me but like circle bullet points. I would look at the CSS.

    Michael Sneed

    All you have to do in case you still need the help is to disable the css like Steve said… around line 1116 in Firebug in Twentyten… from there I assume you’d have to override the declaration in your child-theme.

    .widget-area ul ul {
    list-style: square outside none;


    Ed Altman

    Mystery solved. You’ll laugh (maybe). I certainly appreciate the help.

    The links widget has 4 options, one of which is “Show Link Description”. Unchecking that box removed the funny character.

    I happened upon it because I was setting up links on a test site and dragged the widget over to the sidebar and the options popped open. A little trial and error, and presto, the funny chars are gone.

    Thanks again for the willing help,

Viewing 10 posts - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.