Group Admins

  • Profile picture of Steve

WordPress Troubleshooting and Support

Public Group active 1 month, 3 weeks ago ago

WordPress support from our community

jQuery Cycle plugin

This topic contains 0 replies, has 3 voices, and was last updated by  Michael Sneed 6 years, 3 months ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #1568

    Michael Sneed
    Participant

    I was wondering if anyone knew how to put links into the Cycle Plugin? I’m helping out with this site: http://www.thesarahgracefoundation.com and can’t get a couple of the slides to take links on. Even by mapping them?

    I posted at jQuery.com but know one’s responding…

    #2728

    Chad
    Participant

    Hey Michael,

    Here is the link to show you how if you are going static http://jquery.malsup.com/cycle/anchor.html

    But if you are doing a custom post type you will need to add a custom field to add the diffent link to each slide.

    #2729

    Michael Sneed
    Participant

    Thanks Chad.. I’ll give that a try.. I have a strange feeling that might not work but I’ll give it a try tonight.

    Cheers!

    #2730

    Michael Sneed
    Participant

    Hey Chad,

    It worked really well… the only thing is that the slides that are linked are drawing a larger box outside of the image and it’s covering up the nav menu… you don’t see it in the updated browsers but IE8 shows it..

    Here’s the site again: http://www.thesarahgracefoundation.com

    If you had any ideas that would be great!

    If not, I’m getting a lot closer, which is great!

    Thanks again!
    Michael

    #2731

    Chad
    Participant

    Michael

    you gotta love IE… lol

    I like to wrap my sliders like the one you have in a UL this way i can hide any overflow.
    So my slider would look like this

    Code:
    <div class="featuredPhotos-container">
    <ul class="featuredPhotos"> <!– here is where i would append the jQuery Plugin –>
    <li>slide</li>
    <li>slide</li>
    <li>slide</li>
    </ul>
    </div>

    This way the li tags get the generated style and not the a

    P.S. . or if you can remove the background color #fce4fb; fornt he generated inline styles it seems to fix the problem.

    #2732

    Chad
    Participant

    Sorry can write code in the post.

    Hey WPNYC is there away to write snipplets of code? or how about markdown?

    #2735

    Steve
    Keymaster

    Use the [ code ] shortcode (no spaces)

    Code:
    echo ‘this works’;
    #2736

    Michael Sneed
    Participant

    Thanks Chad for the help.. I tried some stuff on my own.. but no luck.. I’ll try to implement your way tonight or tomorrow!

    Thanks again!
    Michael

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.